1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Snow Leopard Report

Discussion in 'Mac OS' started by paulnajar, Sep 2, 2009.

  1. paulnajar

    paulnajar Senior member

    Well, I did my best to destroy my computer in recent days.

    I got Logic 9 last week and installed it on X.5.8 on my mid 2008 MacBook Pro.

    Then Snow Leopard and a UAD2 Solo Laptop arrived on the same day. I did the OS install straight over the top of the previous system.

    When I first booted into the new OS there was no indication I had even changed anything and that's how it went.

    I've mixed and mastered 2 pretty heavy tracks since then without a glitch of any kind and I'm really enjoying the extra grunt this computer and UAD2 has over my previous studio machine - Dual 2.0 G5 and 2 x UAD1.

    I wished someone made a dual Express34 card adapter that made financial sense so I could run my Multiface PCI on an Express34 slot next to my UAD2.

    Given that I had not really done much serious work on the Laptop with Logic 8 it's difficult to say whether Snow Leopard offer tangible speed benefit but in general internet and office work in 10.6 seems significantly snappier.

    Kind regards
     
  2.  
  3. mk3

    mk3 Senior member

    That's an encouraging report!

    Any third-party plugs that made the upgrade (or did not) which you would care to mention?
     
  4. paulnajar

    paulnajar Senior member

    BFD2, all Camel plugs and CA 5000, Ivory, UAD, Sonalksis, Izotope all passed...
     
  5. akinch

    akinch New Member

    No problems here either Quad Core Xeon 2x2.66 UAD-1 x2

    I did a fresh Install ie erased MAC HD during Installation, LP9 seems to perform better, I open a heavy project with lots of tracks and can now run 64 samples buffer. also all my UAD-1 plugs work, as well as superior drummer 2.0

    Fader port does not, but that was the case with LP9, presonus site doesnt have a LP9 driver yet.
     
  6. Peter Ostry

    Peter Ostry Administrator Staff Member

    Until Presonus delivers a new driver you can remove the Presonus driver from Logic and use HUI instead. Not ideal but works. If you do this, block the Faderport at the "Physical Input" in the Logic environment, otherwise the HUI protocol sends C-2 as an "active sense" signal and may trigger software instruments. Bob ... bob ... bob ...
     
  7. johnpitcairn

    johnpitcairn Member

    Paul also tells me LC Xmu is running fine :)
     
  8. Peter Ostry

    Peter Ostry Administrator Staff Member

    Sure. Are you surprised? ;)
    It's one of the most solid pieces of software we've ever seen.
     
  9. LSchefman

    LSchefman Senior member

    I've got a zillion plugs and most work. Here are the few I've found problematic in Snow Leopard and Logic 9 so far:

    Circle, Predator and Symptohm crash Logic if you run them in Kore 2.1. However, they run fine in Logic as regular plugins.

    Kore 2.1 crashes Logic if you double click on the tempo in the transport window to change the tempo, but only if Kore's GUI window is up; if it's not, then there is no problem. This is also the case with Garritan Steinway and I think one other that I can't remember offhand. However, if you have Kore 2.1's GUI up, you can still change the tempo by clicking and dragging up or down without the problem occurring. Same with Garritan Steinway.

    This must be a bug in either L9 or one of the plugs, because they all don't do it.

    Oddly enough, while Predator behaves oddly with Kore, none of the other RP synths do. And when you click Predator onto the screen, it comes up "backwards" now, i.e., you see the rear of the soft synth with the authorization info, etc. Simply clicking on it returns it to its "front" view.

    Kore crashes Logic when it's updating plugins but only with the Independence Pro update. If you do the update in standalone mode, nothing crashes, and Independence Pro plays nicely with Logic 9 and 10.6, but the font in certain parts of the GUI doesn't look correct. It still works, and is still readable, it just looks kind of "wrong".
     
  10. mk3

    mk3 Senior member

    I'm installing now. I decided to perform the old school clean install, not that there was anything particularly wrong with my old system. It's a habit from the pre-OS X days, I suppose. Erased the system drive, installed Snow Leopard, and am now re-installing all apps. Installing Logic 8 first for compatibility with others who are living in the past. That installation required Rosetta to be installed - which happened automatically, after confirming a dialogue question.

    Anyway, this will take all day.
     
  11. rzzz

    rzzz Member

    Installed 10.6 on a 2009 iMac. Everything seems fine, Stillwell Event Horizon the only plugin that now doesn't work. Logic 9 seems smoother running- or maybe it's just the placebo effect (now that would be an idea for an AU?).

    Rz
     
  12. rzzz

    rzzz Member

    Should have said - did the upgrade install of Snow Leopard. It took about an hour and everything works fine, except for Finder Pop. No real cosmetic change, maybe a bit more alacrity.

    Rz
     
  13. paulnajar

    paulnajar Senior member

    One thing I've come across today is annoying. I'm currently in migration from a G5 tower to using a MacBook Pro so my studio is still wired to a RME Multiface PCI so as a stop gap measure until I get a new audio interface (I'm thinking Fireface UC) I wanted to use the MBP's optical IO to get to the Multiface and use network midi with the help of LC Xmu to control various totalmix functions from my Mackie control rig.

    So it all worked fine except that under Snow Leopard on the MBP the function to tell the apple digital IO to use external audio sync from the optical input is broken and greyed out which means to interface (guessing) ANY mac digitally to anything else means the mac has to be the master sample clock which comes a jittery second to anything RME or pretty much any audio interface.

    It's definitely a bug since Apple mention the function in their online help.

    This is really annoying and pretty much renders the Apple digital IO as useless for anything serious audio wise. I hope Apple are listening.

    Kind regards
     
  14. daveyboy

    daveyboy Senior member

    I can't see going to the hassle of installing SL on my work machine until all the plugins and drivers I have are reported to be working. Or, I get real bored and decide to spend a few hours putting it on another partition to "see what happens"! Are there any reports of any real benefits from using SL this early? Are people seeing small or remarkable performance boosts? I'd love to hear from some full time pros if it's worth doing. I'm sure we'll all do it eventually.
     

Share This Page