1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Some key commands stop working intermittently

Discussion in 'Logic Pro X' started by yavuz, Aug 9, 2013.

  1. yavuz

    yavuz Senior member

    T for tools , for rewind stops working and nothing really fixes this.

    These 2 key commands create a MIDI region instead of doing what they're supposed to do...

    Restart Logic or Mac does not fix it...

    Then it will be OK for a day or 2...

    Any ideas?
  3. yavuz

    yavuz Senior member

    This happens on certain projects...
    They are all started in Logic 9.
    I add an audio track and KCs don't work anymore....
  4. georgelegeriii

    georgelegeriii Senior member

    Have you tried to just reset all key commands? You will loose any custom ones (yea, a bummer for sure) but they tend to work properly after this.

    One other thing you can try is to use the "DisK Utility" app to repair permissions, then reset your key commands, in case something has gotten messed up at a system preference level.
  5. yavuz

    yavuz Senior member

  6. rzzz

    rzzz Member

    I always use the Option key with up/down/sideways scrolling on the Apple mouse. Works a treat to Zoom to whatever view you may want.
  7. georgelegeriii

    georgelegeriii Senior member

    Hi Yavuz,

    the things about your comment that this seems to be happening on certain projects: the key commands is a Logic application preference, not a Logic song specific one. So, whatever is causing the issue, it's unlikely being caused by the key command preference file.

    What happened when you did what I suggested, to the songs that seemed to be messed up?
  8. yavuz

    yavuz Senior member

  9. georgelegeriii

    georgelegeriii Senior member

    can you email me just the file with no audio content? Just zip the Logic song file and send it...

    use my

    george @ georgetechguru . com email...
  10. yavuz

    yavuz Senior member

  11. yavuz

    yavuz Senior member

    I have emailed you the song George...

  12. yavuz

    yavuz Senior member

    It happened again.
    This time a brand new project that started ion Logic X.
    I created a marker with a keyboard shortcut then boom.
    Most keys I press is realised as Keyboard input by Logic Pro X.
    For instance I press G to show global tracks and Logic inputs G3 to the selected tracks MIDI region.
    When I went back one step before in Undo History, I was able to save the project and keep KCs working.

    Is there a Keyboard Input mode that I am activating by mistake?
    If there is such thing how do I deactivate it?
  13. Eli

    Eli Senior member

    Hey Yavuz,

    This sounds to me like it may be a problem with control surface setup/prefs. Try using the rebuild defaults command in the Control Surface menu under the Logic Pro X menu at the upper left. That should do it. If not, check out the Control Surfaces setup window. Maybe trash what's there and rebuild as necessary.

    Attached Files:

  14. georgelegeriii

    georgelegeriii Senior member

    He already tried all that.

    After playing with the file you sent over, it appears that the "G" key enables the "Step Input Keyboard" so you make a G note in your region. The even more bizarre thing: when I press the G key using the search command in the key commands editor, it selects "step Input Keyboard" even though there is no letter assigned to it.

    Try to reassign the "Hide/Show Global Tracks" to another key than G, say F1 or Control/Command G" and see if the behavior stops...

    Yes, seems like a bug to me.
  15. yavuz

    yavuz Senior member

Share This Page