1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Still Horrible Multithreading

Discussion in 'Logic 9' started by tigerman, Feb 15, 2010.

  1. tigerman

    tigerman Senior member

    Hi all, i'm getting glitches and clicks and i have 6 cpu unused, the first one is playing Pong and the other is full loaded like crazy

    so where's this multithreading ??? i have a 4(+4ht) core 2,93 nehalem, and fortunately i've chosen the model with 1 cpu only and higher frequency instead of 2 cpu and lower frequency (for the same price minus or less)

    Logic has a really poor multithreading, it was poor on my older dual core g5 and it's still poor here, nothing has changed since logic 5 on OS9...

    I know that it can't multithread the same signal flow/channel but here it doesn't multithread anything, all sounds even goes to separate outputs!!!

    here's a shot

    maybe on 64bit is better ?
  3. Markdvc

    Markdvc Administrator Staff Member

    I am not familiar with using Plogue Bidule, but looking at the screenshot, it seems that you have quite a few instances of it being used in your mix. I could be quite wrong, but is it possible that Bidule uses one core in logic? In any case, it might be useful, at least for troubleshooting pruposes, to remove several or all instances of Bidule and see what relief that may bring. I realise that this in itself isn't a solution to your problem, but may at least give you some ideas about how to get your mix running a little more smoothly.

    kind regards

  4. tigerman

    tigerman Senior member

    Yes i was experimenting sample accurate syncing between logic and pro-tools and Bidule is the "sync machine" so i should need 1 of that for every channel.
    i understand that probably bidule uses only 1 cpu, but is supposed it should use only 1 cpu for that istance, so you are telling me that if i plug x istances of a single core plug-in they all go to the same cpu?
    Basically multiple istances will be considered like a big one and consequentially they will go to one cpu ?
    I have always thougth that the monothread limitation is referred per istance and not per plug-in...
    Most of the plug-ins are not multithreaded but if it's like you say, it's a big problem (at least for me) :/

    BTW I just want to add that every bidule istance uses 0.6% cpu, it's only a little part of the entire workload, Logic should at least move the other plugs to another cpu
  5. tigerman

    tigerman Senior member

    thinking about it a bit more i know that
    1 - logic can't split workload in the same channel strip, it uses multithreading based on channel strips (eg, if you make a huge channel strip it will always go to 1 cpu)

    and now you tell me that:

    2 - Mono thread plug-ins duplicates will always go to the same cpu

    So basically if i put an istance of the same plug on every channel it becomes a deadly combination, i have all channel using the same cpu :(
  6. Markdvc

    Markdvc Administrator Staff Member

    Yes, that is what the Apple KB about multicore usage seems to say.

    No, I'm not "telling" you anything, just wondering as to whether Bidule might be a contributory factor to your problem.

    I am not saying that at all ... but did you try removing the bidule instances?

    kind regards

  7. Maurits

    Maurits Member

    If that is the case here, then still definitely not ALWAYS. It depends on how the plugin is constructed and not on Logic itself.

    So while I share your disappointment in this case, it should be directed at the plugin programmers and not Logic. ;-)

  8. timrob

    timrob New Member

    Why use Bidule for sync? Couldn't you set up and use the IAC bus in Audio Midi Setup to get sync between Pro Tools and Logic? Maybe I'm missing something, but I don't see why you'd need a Bidule instance on every channel.


    Tim Roberts
  9. tigerman

    tigerman Senior member

    yes it's synched by IAC bus logic master protools slave but it's not sample accurate, and delay changes everytime you press play, with that i get sample accuracy and compensation, basically i arrive with sounds in pro-tools with sample accuracy and in perfect sync with the PT arrange (compensating buffer delays aswell)

    BTW i've tried removing all bidule istances and now i use 5 cpus so it's definitively because of the combination Bidule in every channel, too bad, i think i have to buy vienna ensemble for wrap plugs, it looks much better for that matter, and has rtas also so i'll do that compensation inside pro-tools (assuming it has sidechain support), as in logic i'm gettng some issues in addition to the cpu limitation..
  10. Markdvc

    Markdvc Administrator Staff Member

    Thanks for reinforcing my suspicions. It might make sense to mention the issue of poor multithreading with plogue bidule to its developers. As I understand, it is still early days for them, perhaps they would appreciate and benefit from your feedback.

    kind regards

  11. timrob

    timrob New Member

    Do you have any kind of Word Clock Connection between your ProTools setup and your Logic setup?
    Also, I believe that PT session start needs to be the same as Logic, which by default is 1:00:00:00.

    Tim Roberts
  12. tigerman

    tigerman Senior member

    yes i have word clock and smpte is setted up properly..
    the main problem is logic that doesn't send the exact smpte/midi time clock timing exactly all the times.. Every time you press play there are variation proportional to the audio card buffer size used in logic, so i get an accuracy of about 120 samples if i have buffer set to 128, 60 to 64 and so on...
    To simply understand what happens just put an audio file to both logic and pro-tools, then sync the 2 daws, now press play, and then stop and play again and again.. you will notice that the flange effect with the 2 tracks is not costant but varies everytime you press play, i'm talking about that issue, that everyone using logic as master has, it happens with both smpte and midi time clock sync, someone doesn't care about it, i honestly care, i can't put a sample delay to sync the 2 daws but i need to build somethign that checks that little sample difference all the time i press play and then adjust track delay to compensate for that

    Thanks for your advises anyway ;)
  13. timrob

    timrob New Member

    I wonder if this has anything to do with Automatic Delay Compensation. Both Pro Tools and Logic do it and I'd bet there is a difference in how it's implemented.

    I'm sure you are probably aware of this link to Digi's recommendations.
    But maybe there is something overlooked.


    Finally, I've never used any sync device/operation that can reliably stand up to constant start and stop operations and remain fully synchronized. It almost always takes a couple of bars to lock in. However, it sounds like what you are saying is that it never locks.

    I'm going to have to do some research on this because I have a project where the client is asking if this is possible. I've done it a few times, but honestly have not delved in to the finer points. Mostly I prefer to just print tracks and transfer from Pro Tools to Logic or vice versa and work with a single interface.

    Sorry my suggestions were not more helpful.


    Tim Roberts
  14. tigerman

    tigerman Senior member

    i have tested this thing for many years
    delay compensation does affect the latency but with that turned off or on doesn't solve the issue.
    the best way is to check like i said with 2 identical audio files, you will hear immediately
    that the sync is constant over the track, i mean the syncronization you have is always the same and doesn't change over time but it starts differently every time you hit play.

    first i wanted to sync my logic g5 to plogue bidule on a laptop using midi time clock and i've successfully managed sample accuracy, but i had to do my latency fixer, same behaviour i have now with logic and pro-tools, identical.

    I've tried the opposite, protools master ans logic slave but i think it's worst, because in this case latency changes over time (in fact the audio file acts like a flanger with a slow lfo), and the range is quite high, +-200 samples.
    Similar to logic master - ableton slave, also here ableton latency changes over time.

    the most accurate sync i've found so far is mine :)

    unfortunately i have to find a new way, cause this one limits too much my workflow, i need that damned vienna ensmble to try another solution, they do not even give you a demo until you have bought at least their key dongle, damn, 30 euro only to try it out :/

    Here's a screenshot from a couple of years ago of a sync using logic on mac + bidule on laptop, using only 1 digital mono signal from mac to laptop and a midi in for time clock, all the audio goes throu ethernet using wormhole and will be synched comparing and compensating 2 clock signals.
    I've synched a sequenced instruments in logic (so with no negative delay option) to a sequenced effect in another computer (so i need to anticipate it to compensate for card delay) and then back to logic. the price was high, 6000 samples of total latency, but sample accurate at +-1 sample.
    Using a real sound card instead of wormhole i usually stay under 1000 samples (even less if i lower audio cards buffer size)


    i will write a guide soon as now i have just installed a virtual XP in my mac and i would like to use that glitch and other widows sequenced effects plug-ins again in logci using a wormhole + midioverlan array, or connecting my rme to the virtualized XP if it's possible, so i get real midi e real audio channels....
    I'm already using it for some non-midi plug-ins using wormhole, and with delay compensation active is just perfect. Time to add midi now :)

Share This Page