1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Strange behaviour in Score

Discussion in 'Logic Pro X' started by Jay Denson, Sep 4, 2015.

  1. Jay Denson

    Jay Denson Senior member

    When I change the clef on my viola track it changes the clef on my cello track. And vice versa.

    This does not happen on every movement of the work so I figure it's a bug. Can anyone help please?

    And on another movement I get my viola part split across 2 staves. Any ideas?

    TIA Jay
  3. volovicg

    volovicg Senior member

    You are likely using the same staff style for both. Each should have their own staff style.
    Duplicate the staff style if you are.... Assign different staff styles to each, then modify the clef and it will not affect the other
  4. volovicg

    volovicg Senior member

    Here is a quick video which shows you how it works......
    Remember you can change clefs in the staff style itself ( either on the voice at the bottom or in the graphics in the staff style window to the left) or in the score itself - which is what you see here.
    staf styles.gif
  5. Jay Denson

    Jay Denson Senior member

    Hi Volovicg

    Many thanks for your reply and screenshot.

    I have the parts with independent staff styles selected. Still the same problem. And if I change (by way of experiment) the clef in Violin 1 the clef in Violin2 changes too - in the same way that the viola and cello parts do.

    It's a mystery and very frustrating. Other movements in the same work don't exhibit this behaviour but I get other weird things like the viola part is split into 2 staffs. I just need to save the score and individual parts to pdf's so I can get the works played. I could just copy them by hand (after all, I have the scores which I wrote by hand) - but they would look so much better printed.

    I would appreciate any other ideas you may have. Thanks again, Jay
  6. CSeye

    CSeye Senior member

    Strange behavior like this always leads to me question if the project file may be corrupt in some way.

    What happens if you import the problem staves into a new Empty project using File menu>Import>Logic Project? This function allows you to select any and all tracks, content, among others. While in that window, you're also provided with the Import Project Settings button to import the custom staff styles.

    I would just import the tracks in question using the staff styles in the Empty project. Is the problem behavior still there? If not, then use the File>Project Settings>Import Project Setting function to bring your custom staff styles into this test Empty project.
  7. volovicg

    volovicg Senior member

    With all due respect, his issue is a fundamental understanding of staff styles and their association with regions. This is complicated additionally by him in using two tracks for which parts of each are muted and he wants the score to represent the combination of only unmated regions across two different tracks. So the import recommendation ( while a good one with only the info at hand) is not his issue at the moment. He uploaded his logic project on another forum and I am correcting it now.... Just an FYI
  8. CSeye

    CSeye Senior member

    This business of cross-referencing a question over two discrete forums seems a bit messy.
    Good day.
  9. volovicg

    volovicg Senior member

    Yes I agree. However the OP was put it up on two forums and the other forum allowed for the upload which ultimately ( I hope at least) will assist in educating or resolving his issue. That's what these forums are all about.. right?
    I am only trying to help - don't shoot the messenger!
    Have a great weekend.

Share This Page