Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 System Requirements

Discussion in 'Logic 9' started by livearchive, Feb 25, 2012.

  1. livearchive

    livearchive New Member

    Hey Folks,
    My first post to you. Apologies if this has been asked but I didn't see it. Since I'm running an older Snow Leopard 10.6.3, I was under the impression that I needed to look for Logic 8 rather than 9, based on the system requirements I read on the Apple site (10.6.8).

    Then, I came across this awesome group and its FAQ on Logic 9 and saw that minimum is considered 10.5.7 with a link in that sentence to Apple's site, where it shows the same 10.6.8 requirement. Can someone sort out?

  3. willnubu

    willnubu Senior member

    It depends on which version of Logic 9 you get or have. Logic 9.0.0 can be ran on G5 mac with 10.5.7 as a system requirement. As the updates come, the system requirements change. If you want to run Logic 9 on 10.6.3 or lower, you would need a Logic 9 update that can run on your machine.
  4. livearchive

    livearchive New Member

    Ah! I see. So, I'm currently using an Intel based system w/Snow Leopard (10.6.3). You're saying, in order to run Logic 9, I would need to find an update that would make it run correctly on my side? If so, does such an update currently exist? Thanks for the assistance!
  5. Pete Thomas

    Pete Thomas Administrator Staff Member

    It can be confusing, because when people talk about Logic 9, they would normally mean the latest update to Logic 9 (which is now 9.1.6)

    It is now a download form the Appstore. The only way to get an older Logic 9 would be to buy it used or find a store with some old stock. (I think 9.0 was 2009, 9.1 was 2010)

    But even then, your problem would be how to get the update that is new enough for your version of Snow Leopard, but not too new.

    BTW, don't even bother with trying to get Logic 8, it is nowhere near as good as Logic 9.
  6. livearchive

    livearchive New Member

    This is all very good to know, thanks Pete. I'd love it if anyone else who may know a solution to the 'finding the right old update to 9' could add their views. I definitely want to pull the trigger on this soon as I have a project on tap that I don't want to make the "wrong" decision on...i.e. buying Pro Tools ; 9(.

  7. Markdvc

    Markdvc Administrator Staff Member

    I should mention that the L9 FAQ was written largely after the release of Logic 9.0.0, with some changes made as time went on. Clearly, listing 10.5.7 as the minimum requirement for running Logic 9 is no longer up to date, and I have edited the FAQ accordingly. Thanks for reading it, and bringing this up :thmbup:

    WRT the version of OSX you are using - is there any reason why you wouldn't simply update to 10.6.8?

    kind regards

  8. Pete Thomas

    Pete Thomas Administrator Staff Member

    I just ha a thought...if you install logic 9, then leave it up to apple software installer to update it, presumably it shouln't go beyond a Logic update that wil run on your OS.

    You'd think so but would this happen in real life?

    I'm not sure if 9.0 or 9.1 is what you should start with, was 9.1 a paid upgrade I can't remember.
  9. georgelegeriii

    georgelegeriii Senior member

    One more thing: Logic will not update unless it is in the applications folder and hasn't been renamed in some way. If you put it into a folder of any kind in the app folder it won't update correctly.

    Logic 9.1 was a free update.

Share This Page