1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Time and Pitch Machine 'Greyed out'

Discussion in 'Logic 8' started by Tjsid2000, Jan 22, 2010.

  1. Tjsid2000

    Tjsid2000 New Member

    Anybody else had trouble getting the time and pitch machine to work in the sample edit window. That and several other functions are greyed out, despite me trying it on what seems to be a very ordinary .aif file 16 bit 44.1 kHz...
    Any ideas folks?

    I'm not sure of the version no. of Logic, not near that computer at the moment, but just wondered if anyone knows what the problem might be?

    Any help gratefully received.
  3. Eli

    Eli Senior member

    Just a stab in the dark here - check the permissions on the audio files in question? Try bringing the same file in to a new empty project and see what happens. Try bringing another file into a new empty project; and see what happens. That will help narrow down if the problem is related to a specific audio file or a specific project.
  4. Petrosil

    Petrosil Member

    Probably you try to edit an Apple Loop in the Sample Editor? This does not work, you first have to render or bounce the Apple Loop to a "normal" audio file, e.g. using Bounce dialog, or save a region as new audio file.


  5. Tjsid2000

    Tjsid2000 New Member

    Hi folks, thanks for your help. There are no problems with the permissions of the file and it is a normal .aif file, not an Apple Loop, so I really don't understand it. I'll try the ideas that Eli said and see if they narrow down the problem. Thanks again for your help.
  6. Beerco

    Beerco New Member

    I'm a total novice at logic so take this with a grain of salt - I've had this same issue and I think it's one of two things:

    1) The attention is not on the right item. Depending on how you opened the editor window, logic's attention may not be on the file in the editor window. It will still play and do certain things to the file but won't give you destructive editing options. This is solved by clicking the region once or twice - can't remember.

    2) You're trying to edit a comped track. Until you flatten the comps, you won't be able to perform destructive edits.

    3) something else :)
  7. ButchGTR

    ButchGTR New Member

    I feel for ya brother.. I've had this happen more than once.Sometimes closing out and re opening Logic works ....sometimes rebooting.. sometimes neither.Personally I think it's another pesky logic bug....definte buzz kill...:brkwl: best of luck

  8. biochill

    biochill New Member


    I figured I have the same problem: T&P machine is greyed out, along with adjacent functions in the menu.
    Found out that it is greyed out with mono samples, but it works on stereo samples. I can see the difference within the same song, so it's not just a matter of restarting Logic.

    I wonder why it works on stereo only.
  9. Dahni

    Dahni New Member

    figured it out (sort of)

    Thanks to the clues here, I figured out that mine would only work if the track was an aiff file.

    Weird, but it worked.

    Give it a go.
  10. daveyboy

    daveyboy Senior member

    I've had other weird things happen when the song has had a mix of aif and wave files. In my case I converted the aif to a wave and that fixed the issue. Maybe for certain things to work correctly Logic likes there to only be one file type? For me the issue had to do with consolidating an audio track. It wanted to mix things down instead of just merging. When I converted the track to a wave it behaved normally.

    Sent from my iPad using Tapatalk

Share This Page