1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Track Delay Issue?

Discussion in 'Logic 9' started by holobivv, Dec 24, 2012.

  1. holobivv

    holobivv New Member

    Hello, i wanted to sync up my external midi gear only to find that whenever i set a track delay parameter, it would affect other tracks!

    Let's reproduce it:

    1) let's make a vanilla session with two midi tracks.

    2) the first midi track should play a repeating note like every quarter note

    3) the second midi track should have one note anywhere in the same time with the note event on the first track. just assing it to a different port or a different midi interface, you do not have to connect a sound module or anything.

    4) the second midi track should have a considerable track delay parameter just to make us able to hear its effect. like 200ms.

    play the track. the second midi track that does not have anything in common with the first one will affect the playback.

    I am sure i am doing something, but what?

    any ideas appreciated.

    i made a screen recording of this issue:

    http://youtu.be/WnGh8u5C4qM
     
  2.  
  3. georgelegeriii

    georgelegeriii Senior member

    Not really sure what this is about (if I add a 200 MS delay to a track it won't have anything to do with the other, there will be an obvious delay).

    What are your "plug-in latency" settings set too?

    And could you please try and redefine your issue? I'm not really sure what you are trying to get across. Can you do your example with some chords and piano, or something more definable?
     
  4. holobivv

    holobivv New Member

    Hello, have you checked the video in the video ? Because it shows clearly the problem.

    Trying to explain it the other way, and commenting the video:
    (Please note that the picture and sound are not in sync, the screen recorder did not do it right, but since the problem is so obvious, anyone will understand it)

    -track one plays MIDI PORT 8 on an Unitor 8. a single note as you can see. (plays an external MIDI sampler)
    -track two play MIDI PORT 1 on the same Unitor 8. just single note. nothing connected to it, it does not supposed to do aynthing. it will just mess up track 1 playback as you are going to see that.
    -track two has a track delay setting of 200ms, and muted at start.

    -i play the song, and as soon as i disable mute (0:16) track i will not play correctly anymore where track 2 has its note
    -at 0:20 i reset track delay on track 2 to zero, and the hiccup disappears.
    -at 0:23 i set 200ms again, which messes up track 1 playback again.
    -at 0:28 i mute the region which makes the hiccup disappear
    -at 0:35 i show only track 2 (muting track 1) to show it really does not do anything
    -from 0:39 i'm showing the event list view
    -at 0:46 i switch off the screen recorder and tearing off my hair.

    tried it on another mac with the same midi interface with the same results. tried a different midi interface, same results. what the hell is this?!
     
  5. georgelegeriii

    georgelegeriii Senior member

    I'll ask again:What are your "plug-in latency" settings set too?

    And do you have any other plug-ins in the picture at all other than the midi ones?
     
  6. holobivv

    holobivv New Member

    compensation is set to all. low latency mode is off. the session is vanilla, new, just these two midi tracks. no audio, therefore no plugins.

    despite this, i've disabled the audio engine which made the problem disappear. why?
     
  7. georgelegeriii

    georgelegeriii Senior member

    Try and change those settings and see what happens.

    Also, make sure you don't have any channel strips being used, I have seen people be unaware of something being on their master buss that is causing weird issues.
     
  8. Stevelalonde

    Stevelalonde New Member

    Pretty strange, but that has nothing to do with the plugin compensation in the pref IMO.

    May I ask why you would use the delay in the info?



    Sent from my Nexus 4 using Tapatalk 2
     
  9. holobivv

    holobivv New Member

    Ok, it appears to be a known bug, strange none knew about it here. The order of the tracks have an effect of what track delay compensation is used. But only on MIDI. (George, like i said, there were no plugins or audio channels at all in the whole session!)

    Why delay in the info: you mean the track parameter box? I wanted to use track delay to compensate the timing difference of my external MIDI gear.
     
  10. Atlas

    Atlas Senior member

    Have you noticed the MIDI readout in your Transport. It looks like there are missing note-off occuring because of the delay. It seems that there is either some kind of MIDI loops or notes overlapping. This could be due to the setting in your Unitor, or the notes played here.
     
  11. georgelegeriii

    georgelegeriii Senior member

    Having seen the delay compensation cause problems from tracks that inadvertently have something that is latency inducing on a track, I always double check with people. I'd say to date it's almost always been the problem.

    I guess this wouldn't come up for most people because a) most people don't use many outboard midi devices, and b) I don't know of a single device that would have more than 5 to 10 MS of midi slosh total, so 200 ms delays would never come up.

    Have you ever considered recording the output of the device and using the audio track for time manipulation rather than the midi track? I know it means retracking if you change something, but to my way of thinking, it would bypass the problem wouldn't it?
     
  12. holobivv

    holobivv New Member

    Atlas: if you checked the video carefully, you could see in the event list that there's no such issue. There's no overlapping The problem i outlined causing the note off thing you mentioned. But the note offs arrive indeed, only at the wrong time. On top of that, there's no note-related settings in Unitor 8 (seen that turning off the audio engine in Logic will fix the problem?) not to mention that i ofcourse tried with other midi interfaces. like i said, it is a bug. I've read it elsewhere.

    George: i entered 200ms only to make the effect obvious for you, guys!

    But if you were interested in, some instruments are over 10ms, from the ones i use are Emulator II or the Studio Electronics SE1x. Not that i can live with it or i can do some workaround (though i would not have to if it worked right!). the reason i wrote here is because i hardly could believe such a bug existed in such a strange way, and i was wondering if anyone were aware of it. It's good to know about it anyway, because if one ever wanted to play with this parameter would mess up things seriously.

    In practice however, i like to keep things as tight as possible. You probably know that Logic has a very awkward way of syncing latency. So, having a MIDI device that has 10ms delay and 1-2ms of jitter would not be a problem if there were no latency inducing plugins and no strange rules for compensating these. For example if you insert a lat. inducing plugin to a input enabled audio channel Logic will not compensate for the delay, and will place the recording to a totally wrong position. (Or more precisely: it will place recordings to the right position if the track already has audio region on it. Crazy). And things don't end here the least to say. (I am using Logic as a mixer and effector with an Apogee Symphony IO - maybe my workflow is the problem :)

    Again, i am quite aware of whats going on, the question was strictly about others knowing about this issue and if it could be fixed. I know the answer already. If anyone wanted to give me advice, please take time and check it out. Happy new year! :)
     

Share This Page