1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Trouble recording MIDI with CP 300 in Logic Pro

Discussion in 'Logic 9' started by saw1music, Sep 28, 2012.

  1. saw1music

    saw1music New Member

    Hello,

    I'm trying to record an internal Grand Piano sound from my Yamaha CP 300 by way of MIDI. Up to this point I've been recording all my piano tracks as audio and have had no trouble. Now that I'm trying to record my piano tracks with MIDI (for more editing control), I'm running into trouble with what sounds like some kind of feedback echo (two sounds play at the same time with one of them hanging and messing up the whole MIDI connection). I've viewed several YouTube videos - a couple have been helpful in getting me set-up. In fact, I've been initially successful in recording and hearing playback of my piano. Trouble is . . . that nasty feedback sound always comes back. I've tried to adjust some of the MIDI settings on my keyboard and in Logic but I just don't know enough about the MIDI routing/connections to figure it out. In addition to the CP 300 and Logic, I'm using an Apogee Duet as an audio interface. Does anybody have suggestions about what I might try?

    Thanks,
    -SW
     
  2.  
  3. gdoubleyou

    gdoubleyou Senior member

    Sounds like a midi feedback loop, where midi data is retransmitted by your keyboard.

    Check your keyboard manual, could be a simple fix, check midi mode, and midi thru settings.
     
  4. gdoubleyou

    gdoubleyou Senior member

    Sounds like a midi feedback loop, where midi data is retransmitted by your keyboard.

    Check your keyboard manual, could be a simple fix, check midi mode, and midi thru settings.

    :cool:
     
  5. georgelegeriii

    georgelegeriii Senior member

    Look for the setting "Local on/off" in the Yamaha's "midi" settings, usually in the utilities menu, and turn Logic on to off. That way you only hear the midi track, not both (which is what you hear now, hence the doubling).
     
  6. pfloyd714714

    pfloyd714714 Senior member

    I think George meant for you to turn Local (not Logic) to off.

    Jim
     
  7. georgelegeriii

    georgelegeriii Senior member

    Yep, Apples spell checking gets me every now and then (or the fact that I'm crazy hehehehe). Local to off is correct.
     

Share This Page