Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X turn Varispeed into a regular file?

Discussion in 'Logic Pro X' started by edurbrow, Jun 22, 2016.

  1. edurbrow

    edurbrow Senior member

    If I use the Varispeed and find a tempo I like, how can I turn it into a regular file at that new tempo?
     
  2.  
  3. volovicg

    volovicg Senior member

    what does regular file mean?
    if its a single track you could bounce it out.
    If you have multiple tracks and you want to turn off varispeed, but have the logic project play at the revised speed with varispeed turned off.
    1/ determine the varispeed "speed" in bpm by clicking on the % ( up in varispeed) and change to resulting tempo
    2/ turn off varispeed
    Either of A or B....
    A/ enable flex on audio tracks/regions you have or.....
    B/ edit tempo - detect tempo - then select follow tempo in the region parameter

    Change main BPM to that which was denoted in the resulting tempo of varispeed.
    Your overall project tempo should now be changed.
     
  4. edurbrow

    edurbrow Senior member

    Thank you very much and I apologize in advance for not quite understanding this.

    Yes, that is what I mean. Sorry I couldn't think of how to say that. ;-)

    What if there are multiple tempo changes?

    And then what?

    In the inspector, right? Weird. It was there a minute ago and now it is not there, whether I click on one region or the track header. Okay, I don't understand. When I select my vocal track, it selects all the regions and I am able to click follow tempo, but when I click my harmony voc track, the information in the region box changes. Oh I see, the vocal track doesn't have flex on. I get the A and B choice now, I think. Which is better?
    I tried to do this. I turned off flex. After I selected all the non midi regions I clicked 'follow tempo', but when I clicked on one of those as an individual region it had flex ticked. Anyway, I tried it. What a mess. Some regions changed and some didn't. I don't know what went wrong. This is really a pain when there are multiple tempos. I only have a ritardando at the end in this piece, but I can see how it would be impossible in some other pieces that have slight tempo changes every bar.
     
  5. volovicg

    volovicg Senior member

    Turn flex off on all tracks and regions
    Use follow tempo
    Midi follows tempo changes automatically so only audio should be the focus
    Open global tracks - make tempo visible
    Cmd a to select all nodes. Move tempo map by dragging tempo curve up or down

    So say main bpm on bar 1 is 120 and you have varispeed set to -50%. When you display varispeed in bpm it will say -60.

    Move entire tempo curve looking at bar 1 from 120 to 60. All other tempo information remains relative as long as entire temp map is selected.
     
  6. edurbrow

    edurbrow Senior member

    Ah, I actually put flex on for all the audio tracks and it worked like a charm. I just moved the tempo markers. Is it the same internal process either way with flex or follow tempo? I mean the same algorithm?
    Thanks so much for your help.
     
  7. volovicg

    volovicg Senior member

    No it is not - but for this example either one is fine and either will work. Glad it all worked out in the end. Good stuff!
     

Share This Page