1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

UAD2 in new 8 core

Discussion in 'Mac OS' started by HKC, Sep 8, 2010.

  1. HKC

    HKC Senior member

    Hmm I have just started to install everything on my new 8 core. UAD2 is only recognized in 32 bit kernel mode, that is a fact coming from their own site. The problem is that when I boot in 32 bit everything else behaves very strangely. When selecting the audio and samples drives a flickering sound is coming from the sound card much like a sinus tone but not quite as stable.
    I also have a Powercore X8 and a Raydat.
    When booting in 64 bit this is not a problem but then there is no UAD2 card:-(

    Does anybody have a solution for this
  3. Markdvc

    Markdvc Administrator Staff Member

    Perhaps not a solution, rather, two suggestions:

    - Boot in 32 bit mode to use the UAD card (FWIW, I have both UAD 1e and UAD 2 Quad cards in my 2007 model Dual Quad Xeon, both working fine)
    - Get in touch with UAD and ask them about 64 bit Drivers

    kind regards

  4. HKC

    HKC Senior member

    But the problem is that I can't boot in 32 bit mode. I can boot Logic but not the machine. If I do that nothing else works like it should. The sinustype sound comes from the other drives. Is this maybe an issue that only has to do with the new line.
    Of course I have already written to Universal and told them that they should work harder....
  5. georgelegeriii

    georgelegeriii Senior member

    UA work pretty hard if you ask me.

    That said, 64 bit drivers would be welcome here as well. My computer runs great in full 64 bit mode (Machine and OS and APP). The only audio interface that work out of the number that I have is M-Box 2 Pro. Digi, and a 64 bit driver... who woulda thunk it.

    I did have a hunch: try changing slots... maybe something isn't seated, or there could be a slot issue.

    I have UAD 1s and UAD 2 Duos, and have not had any issue with them (well, other than the latency introduced when one uses them for anything other than mixing).
  6. HKC

    HKC Senior member

    Actually the strangest thing has happened. Since I put something on the two additional drives in the machine the problem has stopped and I can now boot the machine in 32 kernel without getting the sinustone.
    I have posted another thread because I want to make this action the default one so I don't have to hold down 3 and 2 everytime I boot.

    PS I have no complains about Universal either but I use the plugins quite a lot and feared that I wouldn't be able to use them until the 64 bit version came out. If you have TC Powercore you will have noticed that it's not easy to get the OSX.6 drivers running. They seem to be closing in on it now though, my X8 is running decently but I fear what will happen when I actually start to work on my new machine.
  7. HKC

    HKC Senior member

    Now I have found out that the problem with the sinus kind of sound is that my keyboard (Logitech) lost it's shortcuts in 32 bit kernel. No problem with the original apple, neither is there a problem after resetting the shortcuts.

Share This Page