1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 UAD2 Quad Flexi and 64 bit mode

Discussion in 'Logic 9' started by evoclogic, Apr 17, 2010.

  1. evoclogic

    evoclogic New Member

    Hello to all,
    I'm wondering if anyone out there is using a UAD2 quad card and has gotten it to work in 64 bit mode.
    I'm assuming it doesn't work because the AU validator doesn't even see any UA plugs when I try to boot Logic in 64 bit mode.
    I guess I was hoping that 64 bit would solve my dreaded "Memory Low" messages. When I run it in 64 bit I can load a ton of instances of omnisphere, trilian, rmx, kontakt.
    Any light shed on the subject of 64 bit mode and what the possible fixes are for memory management, would be appreciated.

    Best Regards,
    Josh

    mac pro 16 gigs ram
    0S10.6.3
    logic 9.1.1
    UAD2 Quad flexi
     
  2.  
  3. Markdvc

    Markdvc Administrator Staff Member

    Yes, the UAD plugins are working quite well in Logic 9.1.1 in 64 bit mode here, using a UAD 2 Quad, the latest UAD version 5.6 and OSX 10.6.3.

    Have you validated your AUs in 32 bit mode? Can you access the UAD plugins at all in 64 bit mode?

    kind regards

    Mark
     
  4. evoclogic

    evoclogic New Member

    Hello Mark,
    Thank you for your patient wisdom.
    Upon further inspection I realized I was using a very old version of the uad software. I loaded the most recent driver, and revalidated the plugs in 32 bit mode.

    Now everything is working, thank you so much.

    One question, how are you dealing with the whole you can only see one plugin at a time deal? When you want to see how a series of plugs are working together on the stereo mix buss you can obviously only see one at a time if I'm understanding this correctly, any workarounds for this?

    I'm so grateful for all the help I've received on this forum, all of you have been amazing.

    Best Regards,

    Josh Heineman
     
  5. Markdvc

    Markdvc Administrator Staff Member

    Always a pleasure, Josh, you are welcome, and I'm glad it was that simple :)

    Ultimately, the solution is to have all your AUs running 64 bit native. At present, if you need to see several open plugins at once, you have to run logic in 32 bit mode. The AU bridge allows you to run both 32 and 64 bit Plugins in Logic in 64 bit mode, but does have this restriction.

    kind regards

    Mark
     

Share This Page