1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Unsane EXS program changes

Discussion in 'Logic 8' started by Wavetable Jackson, Apr 20, 2013.

  1. Wavetable Jackson

    Wavetable Jackson New Member


    I'm could use a pointer, as my other queries haven't hit the nail yet. On just THREE EXS24 tracks within a Logic project I'm working on, the programs keep defaulting to a hideous synth sweep when I re-open it for a work session. Its like it auto-corrupts itself on start-up. Even Saving after a run-through on Latch doesn't secure the desired sounds in place. The Project's refusal to retain those changes is puzzling.

    Has anyone else had this occur? What am I missing?

    Logic 8, Mac OS 10.5.8, 2.66 GHz Intel Core Duo 2, 2 gb RAM


     
  2.  
  3. georgelegeriii

    georgelegeriii Senior member

    Here is something to look at: program changes on the track. Go into List edit mode, and see if you see a program change there. If so, delete it. Then you should be good to go.
     
  4. Wavetable Jackson

    Wavetable Jackson New Member

    So where ARE the Program change controls?

    Could you be a bit more specific? The List area's events never SHOW a program change option by name, but it sure happens. I see no way to CHANGE it and try to force the new patch to stay put. The Automation track likewise.

    I have dug through the manual. It CLAIMS that "MIDI > Insert Instrument Settings As MIDI Events" will allow you to make program changes, but when clicked, no other box pops up with that function in it. There's no mention of the 1-2-3 of what you DO. I am amazed at this being a problem. I feel as if one last bit of info was left out of the manual.

    Is there any more detail to be had about inserting a program change while a track scrolls by under Touch or Latch modes? If I could do that, I'd already be rolling again. :brkwl: Thanks for the pointer all the same; its another step along the way. :thmbup:
     
  5. georgelegeriii

    georgelegeriii Senior member

    I meant DELETE them. As long as there isn't one, the patch you select will not change. Logic saves this as is. So all samples, and settings for all your plug-ins are saved and will recall. If you use patch changes, this can alter things in unwanted ways... THAT is what I meant.
     
  6. Wavetable Jackson

    Wavetable Jackson New Member

    " I meant DELETE them. As long as there isn't one, the patch you select will not change. Logic saves this as is."

    That's the problem; its NOT saving the patch I select. I never use patch changes within a track. I add a new track per instrument to avoid any such hassles.

    I still don't see any indication of a patch change anywhere. It seems like a glaring lack, because it IS happening, on just three tracks. Somewhere, there would seem to be a switch that turned Pgm Change OFF, period. I could be missing it, admittedly, but that's the issue: WHY does it keep leaping to a new patch on its own on just three tracks? I re-insert the proper ones, re-start the track aaand... pow, its a synth screech again, instead of the organ I entered.

    I can't Delete a CC that doesn't appear anywhere so far and I would THINK there was both a global and a per-track option. Logic sure has everything else! Can you think of any other place to look? This has happened randomly before and I'd REALLY like to take on the skill of stomping that bug. Thanks again.
     
  7. georgelegeriii

    georgelegeriii Senior member

    Look, I thought you might have a patch change, since it seems to me that that is the only way Logic would change an exs sound.

    Sorry for suggesting you might.
     

Share This Page