1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 7 & earlier Using Logic as a Sound Module - Midi lagging though..

Discussion in 'Logic 7 and older Versions' started by 22b, Nov 27, 2009.

  1. 22b

    22b New Member

    Hey Guys, i NEEEEED help pls! :confused:

    Heres my setup.
    I am using an external Sequencer/Sampler (Akai MPC) midi'd up to a Mac running Logic. I plan on using Logic just as a sound module, triggering and sequencing its Audio Instruments from the MPC.

    Now, i have set it all up correctly in Logic and it works.
    (Using 1-16 midi channels from the midi cable, assigned to seperate Audio Instruments within Logic) But i am experiencing quite a midi delay/latency between the time i trigger a midi note from the MPC and when logics Audio Instruments play that note.
    HOWEVER, if i have highlighted/selected one of the audio instrument channels in the arrange, then THAT specific audio instrument will have no midi delay on it and playback instantly when i trigger its notes from the MPC.

    Can this be fixed?? I have read many people using Logic in this manner with success so im confused as to what is causing this problem.

    Any help at all would be GREATLY appreciated.
  3. Markdvc

    Markdvc Administrator Staff Member

    Welcome to the LUG.

    Can you give some more details?

    Which Mac
    Which OS Version
    How Much RAM
    Which Audio Interface
    Whcih Midi interface
    Which OS Version
    Which Logic Version
    Which Buffer I/O Setting
    Which Audio Instruments
    If any, which other Plugins, and whether they are running in any logic channel strips (Instruments, Aux, Bus, Output) which audio signals are being routed through.

    kind regards

  4. 22b

    22b New Member

    Hi, thanks Mark!

    Dual Processor 533 G4 PowerMac
    OS 10.3.8
    1 Gig RAM
    RME HDSP-9632 Sound card & Midi Interface
    Logic Platinum 6.3.3
    Tried 512/256/128 I/O Buffer Setting
    Have tried/tested using JUST 3 ESM/ESP and also EXS24 Audio Instruments.
    No other plugins are used.

  5. Per Boysen

    Per Boysen Senior member

    Use the shift key to highlight/select all of Logic's instrument channels in the arrange that you want to play instantly from the MPC. Holding down the shift key while selecting them one after the other, then letting go of the shift key.
  6. 22b

    22b New Member

    Hello Per Boysen,

    I have tried doing this, except it wont select more than one channel at a time in the arrange.
    Also, which version of Logic are you using?? Maybe its possible in other newer versions to select multiple channels?
    Have you done this before Per Boysen? (Use Logic as Sound Module??)

  7. Per Boysen

    Per Boysen Senior member

    I use Logic 9 now but this worked in 8 as well. With Logic 7 I used to bring a laptop to play Logic instruments by MIDI using an EWI. But I must confess I found it a bit quirky, so today I rather use Mainstage for real-time playback of Logic's instruments by external MIDI. Today I have been toying with two MIDI step sequencing plug-ins driving Mainstage instruments - I guess that's as close as feeding it from an MPC I'll get.
  8. 22b

    22b New Member

    Hey Per Boysen, thanks for the reply.
    Wow.. EWI playing Logic instruments?!? Sounds like good fun.. When you say it was abit quirky, you are refering to the midi timing right?? Midi step sequencer plug ins?? lol amazing.. sounds like a good tool.

    Also, when you did this with Logic, did you need to press play in the transport bar first (get the cursor moving) before being able to play back multiple Audio Instruments? Because right now, i NEED to hit the play button first to hear all the Instruments being triggered otherwise it only plays the channel selected if i dont. Could you confirm that for me please mate? I have a feeling that might be the reason its midi is lagging.
    So Logic 9 is quirky too?

    I dont really want to upgrade my computer etc to get logic 9 or mainstage but if i have to then i might need to save up.. Is it easy recording Mainstages audio output into Logic internally? I plan on using EXS24 alot, does it work with Mainstage 100% ??

    I want to work the same way as this guy -->

    in this example BRYAN MICHAEL COX (producer r&b mary j blige, usher)
    uses LOGIC as a module sound with his MPC4000...


    ""Bryan uses Logic as a sound module," explains Thomas. "He doesn't sequence inside of Logic, he does all his sequencing on the MPC. "

  9. Per Boysen

    Per Boysen Senior member

    The "quirky" thing was having to select the Logic instrument tracks while holding down the shift key. I don't feel very "sharp looking on stage" touching the laptop ;-)) With the L7 setup I was not only playing the synths by external MIDI but also syncing Logic by external MIDI clock (which was not totally stable, another "quirkiness"), a function that is not supported in L8 and L9. No reason to feel sorry for that though, since MIDI Clock is not a very accurate sync protocol. But I use MIDI Clock with Mainstage when I play the synths by MIDI and it seems Mainstage is a lot more stable with MIDI Clock than Logic 7 was, probably because Mainstage has no sequencing engine and only needs the tempo for the beat synced effects.
  10. johnpitcairn

    johnpitcairn Member

    Per's workaround is only good for Logic 7+. The workaround in Logic 5-6 (and maybe 4) is to apply an I/O plugin to each instrument that you want to be in Live mode. You must select input and output for the plugins, then disable the plugins (option-click the plug slot) so they don't actually send anywhere.
  11. 22b

    22b New Member

    Yeah i have tried synching logic externally but i didnt have much luck myself in 6, didnt work ideally.. And thats right, i have heard too that they have dropped support for externally synching logic which is a shame i think. They should bring it back.
    Thats good to hear Mainstage is working good for you bro.. It seems its a stable program. I'll go that route if ALL else fails in the end with logic.

    Hey John! If i am not mistaken, you are an OLDSCHOOL very helpful forum member of LUG. I remember watching posts from you YEARS ago on the forum. Good to see you still here m8! :>
    John somebody else recommended me doing the I/O trick, however when i tried it, it didnt make any difference at all?? I made sure to Bypass each plugin. Thanks for the suggestion though..

    I decided to change the setting for 'I/O BUFFER RANGE' to "SMALL" under song settings--> audio hardware/drivers.
    Although this hasnt completely eliminated the midi Lag problem, it has significantly reduced it. I dont think it will be enough of an improvement tho to work with Logic though, so i am still trying to find answers.

    Per, just one more question- with Logic 7 and above, in order to PLAYBACK the Audio Instruments from external sequencer, did the transport always need to be in PLAY mode (ie: cursor moving).
    I dont think versions above 6 need it to be in Play mode from what i think ive read somewhere. I have a feeling the Transport being in play mode contributes somehow to creating a delay in the playback of midi triggered multiple audio instruments.

    Again, thankyou very much for helping guys.
  12. johnpitcairn

    johnpitcairn Member

    Yes, it's certainly been a while and I can't remember the exact details of the I/O trick. Did you make sure to select an input and output for each plugin?

    If you have cabled from a channel splitter or any other object I think it might only work for the topmost cable - so you may need to cable directly from the physical input "sum" to the sequencer input and use auto-demix instead, and I think the transport also needs to be running.
  13. 22b

    22b New Member

    YESSSSS!!!!!!! SUCCESS!!!!!!! I CANT BELIEVE IT IT WORKS!! :>:>:>:>:>
    Hey John, you are an oldschool LEGEND!! Seriously, you have just made my year! :)
    I went and tried the I/O plugin trick again, and yes, i forgot to choose the input and output in each plugin.. Thats why it wasnt working properly.
    Now, on ANY Audio Instrument track i play from my external sequencer, the timing is ROCK SOLID and ULTRA FAST. Each channel has the exact same response now.
    What can i say, THANKYOU very much John. You have temporarily saved me from buying a new computer/software..lol
    Also, a big thankyou to Per and everyone else for the big help..
    Appreciate your kindness in trying to help. :>
    Have a good new year/xmas every1!

  14. johnpitcairn

    johnpitcairn Member

    Glad to be of help ... not using Logic much these days (making music = a memory, mostly, for now), but my associate is. Logic 9 seems pretty impressive, a few people coming through have been awestruck by flex-time. Just like ProTools, without the hardware baggage.

    Hmmm ... off to "thread for drunk people" for me.

Share This Page