1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Using Roland jv-1010 with seperate MIDI controller

Discussion in 'Logic 9' started by Roblough, Oct 2, 2013.

  1. Roblough

    Roblough New Member

    Hello everyone,

    I'd just like to start by saying I hope I don't annoy anyone by posting this thread. I have literally searched through hundreds of options to try and solve my issue, but I have found no solution that works for my situation.

    I have found other threads that discuss similar issues, but nothing I have found that solves my specific issue

    Essentially I am trying to record a Roland jv-1010 in logic as a MIDI channel. So far I have been able to set up the Roland to "make sounds" in logic by plugging its output into my audio interface (m-audio fast track USB, 1-in 1-out). I can then press the volume knob on the module to produce a 'demo' of each sound, and can record these demos through an audio channel. But I want to control the Roland using a MIDI controller, and record the actual MIDI data rather than just an audio channel.

    Currently I have the Roland plugged in to a Midiman Midisport 2x2 MIDI to USB adaptor, which is running into my computer. The L(mono) out of my Roland is running into the input of the M-audio fast track, using a jack-to-jack.

    I then have a cakewalk a-500s plugged into the computer via USB seperately.

    I have both the Midiman and The cakewalk recognised in the AMS, and have set up the Roland manually, setting the port on port 1 (which is what it is physically plugged into in the Midiman)

    I have set up the Roland in logics environment (correctly I believe) and as I have said, can get an audio signal from the Roland into logic but no MIDI "sound" (if I unplug the MIDI cables, the Roland still produces demo sound through the connection to the audio interface)

    Any help would be greatly appreciated. My only other idea is to run the a-500s into the Roland from the MIDI out port on the cakewalk into the MIDI through on the Roland. But I am out of MIDI cables!!

    This is driving me crazy so if anyone can offer any advice I would really appreciate it.

    Thank you in advance.

    Just to clarify, my set up:
    Logic Pro 9
    Mac desktop (unsure of generation, 64-bit desktop)
    Roland jv-1010 sound module
    M-audio fast track USB audio interface
    Cakewalk a-500s MIDI trigger
  3. Atlas

    Atlas Senior member

    MIDI: A-500s->JV-1010->MIDIMan->Mac->MIDIMan
    Audio: JV-1010->Fasttrack->Mac->Fasttrack->Speakers/cans

    You understand that an audio track is required to record the sound coming from your JV-1010 (via Fasttrack) and another (external or software instrument) MIDI track is required to record the MIDI data (coming from the A-500s (via JV-1010->MIDIMan).

    MIDI is no sound but actuate your sound module which produce (or an instantiated plugin synth) the sound.

    The above connection is not optimal to take advantage of all the Logic feature to modulate the MIDI, but if you can buy more MIDI cables...

Share This Page