Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Vocals out of time with my track!

Discussion in 'Logic 9' started by ncurtis, Jan 10, 2011.

  1. ncurtis

    ncurtis Member

    Bit of a newbie.
    Macbook Pro, Focusrite saffire pro 40, RODE NTK Condenser Mic.

    I've recorded some live guitar, superior drummer & midi keyboard parts. I've come to do the live vocals: set the audio pref buffer to 128 or 64, gone into low latency mode; I sing a take, monitoring via headphones into the saffire. Its out of sync/time with the rest of the track! Not behind, but in front. Try singing a simple 1, 2, 3, 4 on the beat to make sure - same thing, they come in noticeably earlier than the start of the bar...PLEASE HELP!
  3. Pete Thomas

    Pete Thomas Administrator Staff Member

    Strange that the guitar is OK but not the vocals, otherwsie the obvious thing to set is the recording delay. I test this by creating a MIDI click track, then recording it with the microphone and looking at the waveform. I have a recording delay of -72.

    However in your case if the guitar was recorded with the same interface, I would have expected the delay to be the same as the vocals.
  4. georgelegeriii

    georgelegeriii Senior member

    I have the same thing happen sometimes... just use the track delay in the inspector to move the track back in time (or forward if you need to)... in fact, I can't think of a single track recorded in years that I don't nudge back or forth a bit (as a creative thing, not a tech issue).
  5. HKC

    HKC Senior member

    It sounds like you have set the latency compensation to "All", choose one of the other two instead.
    Also remember that there is a way to set the recording delay correctly so you can't just adapt PTs number (-72).
    The right way is to first make a midifile with ie a rimshot on one, turn it into an audiofile (by bouncing it). If you only have a stereo I/O in your card then pan the rimshot hard left, connect L out to R in (select no output for the incoming signal or you will get a fairly annoying feedback to say the least). Record the rimshot and compare the waveforms. You will see that the new one is later than the older one. Reverse the phase of the first one (either in sample editor or with the gain plugin) add a sample delay to the first one. Nudge the delay time until they cancel out each other. Put that number with a minus (-) in front of it into the recording delay field. That's it, the method is the same with a multioutput card except you don't have to worry about the feedback.
    If it's anything else it must have something to do with the soundcard because this has never happened to me while George Leger seem to experience it now and then.
  6. Pete Thomas

    Pete Thomas Administrator Staff Member

    I didn't mean to imply that my offset is the one to use, it was just an example.

    This method is more accurate than mine as I record the click with a microphone, then all I do is look at the waveform, make a selection between beat 1 in the bar ruler and where the recorded click attack transient appears and see how many samples are shown in the yellow info box that appears when you make the selection.

    I have always assumed this is accurate enough for what I do, as well as the fact that using a microphone actually emulates the real world situation.

    But I do think your method is probably much better.
  7. HKC

    HKC Senior member

    PT wrote: I didn't mean to imply that my offset is the one to use, it was just an example

    I didn't think you were, it was just to clear up any misunderstandings:)
  8. Pete Thomas

    Pete Thomas Administrator Staff Member

    I would add that until you are completely confident with any new interface, check the recording delay a few times. When I first got my Apogee Ensemble the delay changed randomly. This was sorted out once they released more stable drivers, but ever since then I have checked before any important session.
  9. michaelo

    michaelo LUG Emeritus

    Dont worry, it just means you are singing too fast!!
    No really... this problem I have encountered once or twice too. Somehow the audio you just recorded get excluded from the additive plugin delay compensation and ends up playing early. My fix has usually been to exit and reboot. Seems to make it go away.
  10. ncurtis

    ncurtis Member

    Hi , Thanks.
    The guitar was recorded on an earlier occasion; there wasn't a problem before. I have even done some vocals without a problem. This seems to have come out of nowhere!
  11. ncurtis

    ncurtis Member

    Hi, Thanks.
    What if it doesn't go away when I reboot?
  12. ncurtis

    ncurtis Member

    Hi, Thanks.
    I can look into doing this when I get home, but, I don't want to have to do this every time I record a vocal. Something's wrong here surely. thing is, I'd rather it JUST DIDNT DO IT!!! Also, I'd like to know why it's happening so I can fix it. Spent a shed load of money on this and I'd love if it just worked. Never had this with my trusty AW4416. Thanks for your suggestion though.
  13. Pete Thomas

    Pete Thomas Administrator Staff Member

    have you tested the record delay, using either HKC's or my method?
  14. ncurtis

    ncurtis Member

    The Recording Delay is in audio preferences...the bar thingy? Mine is currently set at -5000. Should it be set at 0 as default? Is this what's causing the problem? I havent yet tried the test, I'm not quite sure how to do it?

    Run through...
    open ultrabeat? drop a click/kick into the arrange window.
    open an audio track, play, record the kick via the mic from the monitor?

    then you say look at the waveform, what does this mean? Shoul dI be looking for a number somewhere? where will this be ? then I set the 'recording delay slider to this number?

  15. Eli

    Eli Senior member

    5000!!! Umm, yeah; I'd be willing to bet that's the problem! It should be at 0 by default, and possibly offset slightly from 0 after you do the record delay test. But it shouldn't have to be anywhere near 5000 with any kind of modern audio interface.
  16. FUBARd

    FUBARd Member

    Then try delay comp.

    lol too slow... never mind
  17. ncurtis

    ncurtis Member

    I must have changed it by accident. Its back on 0 and working just fine.
    Thanks all.
    Feel like a silly boy now.

Share This Page