Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 warp tool dragging audio section backwards

Discussion in 'Logic 9' started by Calumjc, Sep 12, 2013.

  1. Calumjc

    Calumjc New Member

    Hi all,

    im relatively new to logic so forgive me if im missing something obvious.

    when i use the time warp tool on a section and enable the section, the first click with the tool compresses that entire section backwards relative to how far along it i click.
    Also, clicking on the channel strip on arrange view makes that channel bigger than the rest.

    its driving me insane as i cant get anything done, is there something i need to turn off or a button i need to press?

    thanks
     
  2.  
  3. mt100uk

    mt100uk Senior member

    Hi, the best way to think of flex editing is as a bit of rubber with each end stapled to the start end end points of the audio region. If you pull it one way, one half of the rubber will be stretched and the other compressed and that's what logic is doing to the audio. One way to do it is to split the region up, the other is to use flex points as additional "staples" to fix that point and then the other side of this marker will be unaffected by any movement. This works for medium to moderate movements, for anything more you'll need to start splitting regions and overlap/cross fade etc.

    As to the channelstrip zoom thing, it sounds like you've got auto track zoom enabled, not in front of it at the mo and I can't remember the standard key command, have a look in the key commands dialogue.

    Mike
     
  4. Calumjc

    Calumjc New Member

    Hi Mike, thanks for the reply.

    I dont think i explained my self clearly before so i took some screenshots to illustrate my point.

    below is the before shot. a double tracked vocal in need of some alignment:
    [​IMG]

    the top track is what im trying to align it to and the bottom track has been flex enabled. when i select the flex tool and click the bottom region (with or without dragging) it moves the audio like in the screenshot below:
    [​IMG]

    the amount the audio is moved depends on how big the region is (i cut either size of the clip and it is moved less)

    i bet i've just enabled something by accident but i have no idea what
     
  5. mt100uk

    mt100uk Senior member

    Hi, any chance you can hit command + F to toggle flex view, it'll show more of what's going on
     
  6. Calumjc

    Calumjc New Member

    i clicked it with the warp tool and then enabled the view, hope this helps.
    on a side note, undo will not work to put it back to normal (it did before now).

    [​IMG]
     
  7. mt100uk

    mt100uk Senior member

    Hi, to me it looks like the region was probably split from a region that had already been flex edited. The green tint indicates that it is stretched (orange indicates its been compressed.) you should be able to reset the flex by right clicking (Ctrl + left click) and select "delete manually created flex markers" or delete all flex markers. Going back to the analogy of a length of rubber it appears as if you've pulled it to the left (and essentially stapled it there) then when you split the region (essentially putting two staples next to each other and cut the piece of rubber between them) the right hand section is still under tension.
    My method for using flex is (starting from the left) is insert a flex marker before and after the bit I want to change (thus stopping subsequent and previous bits from moving) and then move the bit I want into place.
    When using flex tool all parts of the region will be moved unless you "lock off" the bits you don't want to move by inserting flex markers or splitting the audio region (before you make any edits.)
     

Share This Page