Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Weird "Transposition" behavior on the MIDI Thru of different MIDI Instruments

Discussion in 'Logic 8' started by mDay, Apr 10, 2009.

  1. mDay

    mDay Member

    The problem is...if I'm playing a MIDI Instrument and I want to have the MIDI Thru set to one octave lower (-12), this setting becomes universal for ALL my MIDI instruments and AU Instruments. This never behaved like this in any other previous version of Logic as each MIDI instrument/AU Inst. had independent MIDI Thru settings. Any thoughts or suggestions? Thanks in advance!
  3. Eli

    Eli Senior member

    You're setting it in the wrong place. When you alter the midi thru settings with no region selected; it applies the parameters to any newly recorded regions. It is behaving exactly as it should.

    Reset it back to defaults. What you need to do is alter the transpose setting in the Instrument Parameter Box. This is located immediately below the Region Parameter Box. You may need to flip open the little disclosure triangle to view all the parameters. But this is where you can set instrument specific parameters like transpose.

    This is the exact same way it has always been. It's just that the Inspector section of the Arrange Windows looks a little bit different than it did before. So, it's easy to not recognize the different areas without looking closely.
  4. Doug Zangar

    Doug Zangar Senior member

    I thought MIDI Thru always behaved as a global setting - that's how I remember it, but I never use the setting much. Since it's global, why not just use your transpose feature in the instrument parameter box?

    Edit: Eli, you are a too fast - I started writing this, got a phone call, posted it - and you had already covered it it nicely!
  5. mDay

    mDay Member

    Thank you! That's what I was missing. Funny enough I always have the Instrument Parameter Box visible and I didn't realize there was a separate Transposition setting there. I could swear I never had to think in terms of 2 separate parameter boxes in previous versions of Logic. Oh well...thanks again and for the quick reply!

Share This Page