1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Where have my track buttons gone?

Discussion in 'Logic 9' started by David51, Oct 17, 2010.

  1. David51

    David51 Senior member

    I am wondering if this is just me or has any one else had this behavior.The buttons for Input Monitoring and Record Enable won't show up when I try to configure them.

    Could it come from having all 6 tracks in protect mode?

    Is there a way to move the MIDI tracks to a new song template without bouncing them? Export aas MIDI file!

    Does any one believe that will be the answer?

    Would rebuilding the HDD with Disk Warrior help?

    I will close the project and sto Logic, then start it again and see if that bumps the old girl into a logical behavior. I still would like to know if others have had this, i am still in 9.1.1 and will definitely use Owen's zip method for 9.1.2-but if the installer can't find Logic Pro it won't install the 9.1.2.

    So making a copy of the Logic folder in applications and zipping one is what is needed,no?Owen?
  3. Markdvc

    Markdvc Administrator Staff Member

    David, what sort of Channel Strips are you referring to?

    Here is a screenshot of a very basic logic arrangement showing, from the left in the mixer, one each audio (Audio 1), instrument (EVP88) and midi (GM) channel strips:


    I presume that the Owen you are talking about is none other than Orren :)
    Zipping Logic Pro creates a zipped copy, leaving the original, so you are safe to do this.

    kind regards

  4. CSeye

    CSeye Senior member

    Hi David,
    Are you right-clicking or control-clicking on the Track Header in the Arrange window to "Configure Track Header" ? You can check the buttons at the bottom that you want to appear.

    If you're doing that and saving your project, but the buttons don't appear next time you open the project, then the project file might be corrupt.

    If you need to salvage tracks already recording you can use the procedure that I've outlined below.

    Download the document Import2 here. It's a quick tutorial I threw together.

    It's easier to select all (command-A) to select all project elements rather than shift-clicking as I indicated in Import2.
  5. Eli

    Eli Senior member

    Is it possible you have your screen set locked? This would account for not having track header changes appear when the project is reopened, or the current screen set is recalled.
  6. CSeye

    CSeye Senior member

    Excellent point!
    A locked screen set would certainly be a more obvious suspect that I didn't consider.
  7. David51

    David51 Senior member

    Hi and Thanks to you all for your help-I think Eli has found my mistake-I did not see in the Manual that locking would stop configuring the TRACK HEADERS-I will open Logic now so this thread doesn't become too long. No it ain't the Locked Screen:>( Many thanks Eli,great idea, I also turned all buttons off and then back on but only the three you see are available:M,S, and protect.

    CSeye,Thanks,here is screenshot:
    http://img.skitch.com/20101018-m4ejh2ukdk2iupjwgg8jp2aty3.jpg as you see its the track headers,but the channel strips that should have one[inst.not MIDI GM] don't either. Thanks for the tutorial, it probably is a corrupt file, but I will first run Disk Warrior to rebuild the HDD as this has been the solution to many quirks I make my Mac do.
  8. CSeye

    CSeye Senior member

    Input Monitoring isn't enabled on software instruments tracks as shown in your screen shot. It will show up on audio tracks.

    Record Enable will not appear on locked tracks. Unlock the tracks. The button turns gray and shows an open lock. The Record Enable button will then be visible.
  9. David51

    David51 Senior member

    WOW! CSeye Thank you. That was it, as you said when I unlock the track the record enable button appeared, It is wonderful to have such knowledgeable people to ask and they all are willing to help. Sorry Orren for not remembering your name, I can't even remember where in the Manual the protect =no record info. I am going to see where it is hidden. Again thanks to you all for the help,now to make some more music, what a relief.

Share This Page