1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 7 & earlier which version of logic do I need to use?

Discussion in 'Logic 7 and older Versions' started by lougique, Mar 20, 2012.

  1. lougique

    lougique New Member

    Hello all,
    I use a Power PC G4 Mac Mini, OS 10.5.8, and Garage Band version 5.1.
    I know this sounds dinosaurish.....
    Anyway, can anyone kindly advise me which version of Logic would work with this set-up? and if it's still possible to make it happen actually, or is my system just too outdated?
  3. georgelegeriii

    georgelegeriii Senior member

    Try 8 or even 7 if you can get a key.
  4. lougique

    lougique New Member

    Thanks George.
  5. Condo

    Condo New Member

    I sent you a PM with a possible solution.

Share This Page