Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Why do I get "memory getting low" message

Discussion in 'Logic 9' started by maxim, Sep 12, 2010.

  1. maxim

    maxim New Member

    Hi folks,

    I'm trying to score a fullsize cinema project. Loads of channels, yes. Mostly Kontakt 4 and Miroslav Philharmonik. Now I am getting messages like "Memory is getting low. Try to disable some plug-ins".

    I am on a MacPro Quadcore 2,66 with OSX 10.6.3 an Logic 9.1 (32 bit) with 9 Gig RAM.

    When I check the memory statistics it states 1,78 Gb for Logic and another 350 Mb for Kontakt's memory server. About 6 Gb are free !!!

    I don't switch to 64bit mode because a number of my plugs will not work in that mode.

    Why do I still get those messages ? Is there I way I can optimize ? Freezing ? Changing buffer size ? Will it go away if I increase my RAM ?

    What can I do :confused:

    thanks for hints

  3. Markdvc

    Markdvc Administrator Staff Member

    Even though you have 9 GB, it is important to bear in mind that any 32 bit program can adress a maximum of somewhat less than 4 GB RAM.

    This is exactly the sort of situation which 64 bit mode is intended to deal with. Which of your plugins don't run in Logic in 64 bit mode? Have you contacted the developers to ask when they will have 64 bit versions?

    You could also look into running Sample libraries outside of logic - VSLs Ensemble Pro as well as plogue bidule are used this way.

    kind regards

  4. georgelegeriii

    georgelegeriii Senior member

    Logic 64 has a 32 bit plug-in bridge, so you actually can use 32 bit plug-ins. All the current sample engines (Play, VSL, Kontakt, and more that I can't remember off the top of my head) have 64 bit memory servers so they aren't usually the cause.

    I did have one client who reboots his system every couple of hours and cues, just to keep things working smoothly. He used to see the same prompt, and discovered it was because the Kontakt server doesn't always give back all the ram it tries to use when he loads new sounds while looking, unless he deletes the current kontakt instrument before loading a new one
  5. maxim

    maxim New Member

    Hi George,

    I do exactly that - reboot my system now and then.

    Will try the 64 bit mode now ! Thanks.

  6. Robert Wilson

    Robert Wilson Senior member

    I recall seeing a thread on another forum (Gearslutz maybe?) saying that L9 was guilty of this itself. I never got around to trying to check this myself, but I occasionally have to reboot too. (Not due to Kontakt - I don't use it.)
  7. mk3

    mk3 Senior member

    There might be a memory leak, perhaps in a third party program. I experienced this recently in a long session where I had to keep closing and opening different projects. None of them were particularly large by themselves, but over time I started getting the low memory error, even though I have 18GB of RAM. All other programs were closed. I checked the free memory in iStat and the free memory was actually down to a few k! Nothing seemed to help but a reboot.

    Not sure if the problem was with L9 or perhaps a third-party plugin...I use Kontakt for my sampler, and various EastWest/Quantum Leap Play products also, both in the latest versions.

  8. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    That problem can be caused by your "Undo History" getting too large. You can set your preferences to track fewer "undos." You can also manually delete the "undo history" every so often.

    My son had the same problem with his orchestral templates, and he uses Miroslav and East-West. In his case, he could only let the undo history grow until three "undos" before Logic (he was using 8 at the time) would get quirky. I came across the issue way back at 5.51 for PC. Seems to me the memory error message is not as specific as it could be: i.e., "Arrrgh! Delete your undo history to proceed..."

    From Logic's main menu, select "Options --> Project Info" to see how much memory your undo steps are using. If there is no usage, it should say 24.

    To reduce the number of undo steps the system tracks, select "preferences --> general --> editing" from Logic's main menu.
  9. Robert Wilson

    Robert Wilson Senior member

    Thanks. I haven't heard this before.
    I've reduced my Undo history from 30 to 20 and will see how we get on.

Share This Page