1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 why doesn't Logic start recording where I tell it to?

Discussion in 'Logic 9' started by brianbotkiller, Dec 6, 2010.

  1. brianbotkiller

    brianbotkiller New Member

    Ok, so this is something that drives me nuts about Logic.

    I want to start recording at bar 8.5, let's say. I set my transport to half way thru bar 8.

    Then, I want a count-in of 2 bars, and to only hear the metronome on count in. I make those settings, ok, all's fine.

    Now, I record arm my track, hit record - and logic arbitraily jumps backwards two and a HALF bars back for count in. So, it goes back to bar 6, begins count in - which means that I have half a bar without the count in click I wanted, which is herky jerky and weird.

    If I jump to bar 8 and start recording, it'll go back 2 bars, to bar 6, and count in. Ok, that's fine; but why is it randomly deciding to go back 2 1/2 bars in the other instances?

    Perhaps I'm being stupid, and I apologize if so, but I have checked every possible setting and this has always been something that's bugged me in Logic.

    Thanks.
     
  2.  
  3. Pete Thomas

    Pete Thomas Administrator Staff Member

    I think this is probably a case of Logic being developed first of all for the most usual way of working. There is no option for a count in to lead to anything but the first beat of a bar.

    In this case I would start my recording at bar 9 and set a 3 bar count in so you then get the count right up to (and slightly beyond) the 3rd beat of bar 8 (assuming for example you are in 4/4). I then merely need to pull the start of the recorded audio back from bar 9 a couple of beats.

    I do see your point, but I imagine the Logic developers work first and foremost on what their users (and marketing department) ask for. Making the count options more complex if many users are not complaining about it is not likely to happen, as they would prioritise what everyone is clamouring for, so I'd suggest looking for workarounds (as above) until then.
     
  4. Eli

    Eli Senior member

    You could try using the pre roll setting on the recording page of the project settings. But it seems like this is formatted to only work in a minute/seconds timebase; not bars and beats. I think, like what peter said, that users working to bars and beats usually opt for count ins of full bars. And the pre roll option is there for people working free of the bar/beat grid.

    To get what you are after, have you tried exploring the autopunch options? Although not exactly what you are looking for, this might do the trick for you and be the most practical work around.
     
  5. brianbotkiller

    brianbotkiller New Member


    Yeah, auto punch has been the only way to really get around it. Still drives me a bit nuts, but oh well ;)
     

Share This Page